[Jenkins] 2.85以降のバージョンにおけるプロトコルエラー

環境

環境 Ver.
Jenkins 2.74->2.86へ更新

エラー

https://jenkins.io/security/advisory/2017-10-11/
上記セキュリティリスクが報告された為、2.74から2.86へバージョンを更新した。

This Jenkins instance uses deprecated protocols: JNLP-connect,JNLP2-connect. It may impact stability of the instance. If newer protocol versions are supported by all system components (agents, CLI and other clients), it is highly recommended to disable the deprecated protocols.

このJenkinsでは、廃止予定のプロトコル “JNLP-connect”、”JNLP2-connect”を使用している。
新しいプロトコルのバージョンがシステム構成要素(エージェント、CLI等)でサポートされている場合、インスタンスの安定性に影響する可能性がある為、廃止予定のプロトコルを無効にすることを推奨する。

2.85以降のバージョンで発生するようだ。

対処方法

http://{YOUR_DOMAIN}/configureSecurity/ のページにて、”Agent Protocols” のチェックを全てはずし、廃止予定のプロトコルを全て無効にする。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です